System Health

Our system health is a real-time view of the performance of Employee Advocacy. Bookmark this page and check back if you experience any interruptions.

Subscribe to Updates

Bambu Environment Access Issues

Incident Report for Employee Advocacy

Resolved

The issue with intermittent access appears to be resolved. Please subscribe to receive status updates
Posted Nov 09, 2021 - 13:56 CST

Investigating

Bambu is currently experiencing intermittent access issues and our engineers are investigating the root cause of the problem. Please subscribe to receive additional updates. We apologize for the inconvenience.
Posted Nov 09, 2021 - 12:59 CST
This incident affected: Employee Advocacy - Web Application.