System Health

Our system health is a real-time view of the performance of Employee Advocacy. Bookmark this page and check back if you experience any interruptions.

Subscribe to Updates

Missing Twitter Metrics

Incident Report for Employee Advocacy

Resolved

The issues with Twitter affecting post metrics appear to be resolved.
Posted May 22, 2023 - 15:27 CDT

Update

Twitter metrics have begun returning but are not fully restored yet. We are still monitoring the situation and apologize for any inconvenience.
Posted May 19, 2023 - 10:38 CDT

Monitoring

Twitter is currently experiencing difficulties that affect post metrics since May 12, 2023. We are monitoring the situation and apologize for any inconvenience.
Posted May 18, 2023 - 13:33 CDT

Investigating

Employee Advocacy has been experiencing issues pulling in Twitter post metrics since May 12, 2023. Our engineers are actively investigating the root cause of the problem and are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted May 17, 2023 - 17:13 CDT
This incident affected: Employee Advocacy - Web Application.