System Health

Our system health is a real-time view of the performance of Employee Advocacy. Bookmark this page and check back if you experience any interruptions.

Employee Advocacy Issues Opening Application

Incident Report for Employee Advocacy

Resolved

A fix has been released and the application is back to normal operation. We apologize for any inconvenience.
Posted 10 months ago. Jul 30, 2024 - 12:14 CDT

Identified

Employee Advocacy is experiencing degraded performance. We have identified the issue, and are working on a fix
Posted 10 months ago. Jul 30, 2024 - 12:03 CDT
This incident affected: Employee Advocacy - Web Application.