System Health

Our system health is a real-time view of the performance of Employee Advocacy. Bookmark this page and check back if you experience any interruptions.

Subscribe to Updates

Twitter Issues

Incident Report for Employee Advocacy

Resolved

The issues with Twitter appear to be resolved. Please subscribe to receive status updates.
Posted Feb 08, 2023 - 17:46 CST

Monitoring

Twitter is currently experiencing difficulties that affect various Advocacy features. We are monitoring the situation and apologize for any inconvenience. Please subscribe to receive status updates.
Posted Feb 08, 2023 - 16:32 CST
This incident affected: Employee Advocacy - Web Application.