System Health

Our system health is a real-time view of the performance of Employee Advocacy. Bookmark this page and check back if you experience any interruptions.

Subscribe to Updates

X/ Twitter Outage

Incident Report for Employee Advocacy

Resolved

This incident has been resolved.
Posted May 09, 2025 - 16:33 CDT

Monitoring

X's service is operational and we are monitoring the results.
Posted May 09, 2025 - 14:59 CDT

Investigating

X is currently experiencing difficulties that are affecting Employee Advocacy. As a result, you may experience issues publishing/ retweeting to the network, as well as problems viewing reporting data for Tweets in Advocacy.

We are monitoring the situation and apologize for any inconvenience. Please subscribe to receive status updates.
Posted May 09, 2025 - 13:38 CDT
This incident affected: Employee Advocacy - Web Application.