System Health

Our system health is a real-time view of the performance of Employee Advocacy. Bookmark this page and check back if you experience any interruptions.

Subscribe to Updates

Employee Advocacy Login Issues

Incident Report for Employee Advocacy

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:02 CDT

Investigating

Employee Advocacy is experiencing degraded performance. Our engineers are currently investigating the root cause of the problem. Please subscribe to receive additional updates. We apologize for the inconvenience.
Posted Oct 21, 2025 - 12:57 CDT
This incident affected: Employee Advocacy - Web Application.